メモ。

ただのメモです。

laravel5.1でlaralib\L5scaffoldを使う

vendor/laralib/l5scaffold/src/Commands/ScaffoldMakeCommand.phpを修正するところがポイント。

$ composer create-project laravel/laravel <PROJECT> "5.1.*"
$ composer require 'laralib/l5scaffold' --dev

$ vim vendor/laralib/l5scaffold/src/Commands/ScaffoldMakeCommand.php

use Illuminate\Support\Composer;
        ↓
use Illuminate\Foundation\Composer;  //修正

$ vim config/app.php

# providerのところ

Laralib\L5scaffold\GeneratorsServiceProvider::class,  //追加